设为首页收藏本站

IT技术擎 - 最棒的IT web技术交流社区

 找回密码
 注册为IT技术擎人

QQ登录

只需一步,快速开始

搜索
热搜: php h5 jquery
查看: 9|回复: 0

[工具应用] Maven项目常见错误解决方法汇总

[复制链接]

5869

主题

5869

帖子

1万

积分

版主

Rank: 7Rank: 7Rank: 7

积分
17963
发表于 2018-1-10 22:50:36 | 显示全部楼层 |阅读模式
issue 1、Java compiler level does not match the version of the installed Java project facet.
或者 One or more constraints have not been satisfied.
或者 Dynamic Web Module 3.1 requires Java 1.7 or newer.

解决办法:
在项目中的pom.xml文件中添加以下配置: 说明:以下是根据你自己使用的jdk版本来配置的,我本地使用的是jdk1.8,所以配置的是1.8
  1. <
  2. build > <
  3. plugins > <
  4. plugin > <
  5. groupId >org.apache.maven.plugins </groupId > <
  6. artifactId >maven-compiler-plugin </artifactId > <
  7. version >2.3.2 </version > <
  8. configuration > <
  9. source >
  10. 1.8 </source > <
  11. target >
  12. 1.8 </target > </configuration > </plugin > </plugins > </build >
复制代码
之后选择项目右键,选择maven,然后选择Update Maven Project更新一下项目就可以了解决以上问题了。或者使用快捷键(ALT + F5)
该用户未在地球留下任何的痕迹

本版积分规则

QQ|小黑屋|帮助|IT技术擎 ( 沪ICP备15054863号  

GMT+8, 2018-1-21 06:54

Powered by Discuz! X3.2 Licensed

© 2001-2013 Comsenz Inc.

快速回复 返回顶部 返回列表